nixos/hosts/delta/network.nix
Pablo Ovelleiro Corral 2103ab9f6e
Update NixOS wiki link
2024-06-27 20:37:34 +02:00

24 lines
536 B
Nix

{...}: {
systemd.network = {
# Main interface
# https://wiki.nixos.org/wiki/Install_NixOS_on_Hetzner_Cloud
networks."10-lan" = {
matchConfig.Name = "enp1s0";
address = [
"159.69.4.2/32"
"2a01:4f8:1c0c:70d1::1/64"
];
routes = [
{routeConfig = {Destination = "172.31.1.1";};}
{
routeConfig = {
Gateway = "172.31.1.1";
GatewayOnLink = true;
};
}
{routeConfig = {Gateway = "fe80::1";};}
];
};
};
}